techtipsandtricks

Jan16

Auto-Recover & Backup

Categories // Installation, 3D CAD, Tips & Tricks , Contact Support

Is your's working properly?

Created by Enrique Garcia, Application Engineer

 

SOLIDWORKS has two very handy functionalities in case things go south when working with SOLIDWORKS.  To help save hours worth of work SOLIDWORKS has a backup function that will save versions at different save states in a directory of your choosing.  Also in case you have failed to hit the save button, SOLIDWORKS has an auto-recover functionality that will periodically look to log unsaved changes.  If these functions are already set up, we will show you how to check that these two functions are working property.

To check that Auto-recover is functioning properly please do the following:

  1. Open the SOLIDWORKS System Options and navigate to the Auto-recover settings from Tools > Options > System Options > Backup/Recover
  2. Open a Windows Explorer Window and navigate to the directory shown for Auto-recover
  3. Back in Auto-recover settings reduce the time setting to “Save auto-recover informatino every” value to 1 minute and select ok
  4. Start a new SOLIDWORKS part, after 1 minute a file named: “AutoRecover Of PART_NAME.SLDPRT.swar” will appear in the directory
If this file from step 4 appears in the Auto-recover directory then the SOLIDWORKS auto-recover functionality is working properly.  See the below image, we have worked on this part file and after 1 minute the file appeared in our Auto-recover directory automatically.
Test Auto Recover
To make sure the Backup functionality is working correctly do the following:
  1. Open the SOLIDWORKS System Options and navigate to the Backup settings from Tools > Options > System Options > Backup/Recover
  2. Open a Windows Explorer Window and navigate to the directory shown for Backup
  3. Back in the Backup settings modify your “Number of backup copies per document” and set to your desired number.
  4. Start a new part file and add a feature and save your model.  You should now see a file named “Backup (1) of PART_NAME.SLDPRT” in the directory.
  5. Add another feature and hit save again you will see a new file named “Backup (2) of PART_NAME.SLDPRT”
If these files start to appear in your Backup directory then the backup functionality is working properly.  If you continue to add features to your part and hit save, you will continue to add new backups in the directory up to the number specified in step
3.  Backup (1) will always be the newest backup version and all other save states will be renamed in sequence keeping the oldest save state as the highest backup number.  The below example has a number set to 5 copies per document.
Test Backup
If you are not seeing the expected files in the Backup/Recover directories try the following to troubleshoot the issue:
  1. Make sure you have the correct read/write permissions to that directory.  Try creating a notepad file and saving it to the same directory to see if other files work correctly.
  2. Change the location of backup and auto-recover to another location.
  3. Try repairing SOLIDWORKS.